Office Phones Down
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted 5 months ago. May 07, 2019 - 07:54 CDT
Monitoring
Office phone and internet connectivity has been restored, but we will continue to closely monitor.
Posted 5 months ago. May 06, 2019 - 17:03 CDT
Investigating
We are aware that office phones, including internet access, is down for the Gulf Breeze location and are investigating.
Posted 5 months ago. May 06, 2019 - 16:51 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).