Exchange/CP Sluggishness
Incident Report for AppRiver
Resolved
We continue to examine all aspects of this issue both internally, and in conjunction with Microsoft to fully address the underlying cause of the Exchange latency that was experienced by some customers last week. Integrated within that process, we’re still working on the root cause analysis. However, network performance and mail flow remains at optimum levels and we continue to see no customer impacts associated with this issue. Throughout the extended troubleshooting process, we discovered other opportunities for efficiency and we are working to fully incorporate those, as well.

We’re marking the issue as resolved from a customer impact standpoint, but we continue to closely monitor and adjust the Exchange service for performance and efficiency. A root cause analysis will be available once the validation process has been completed.
Posted 6 months ago. Mar 13, 2019 - 12:02 CDT
Update
We continue to monitor the Exchange service for any connectivity issues, but performance is still fully tracking as optimal. So far, the only issues we have discovered have been with a few customers who haven’t restarted their mail client since last week and were still receiving authentication requests. Once the mail client was restarted, all authentication and password prompts cleared. No other negative impacts or latency issues have been identified.

Our engineering team is still working through the validation process and we’ll post more on the final details and the root cause of this issue when that process has been completed.
Posted 6 months ago. Mar 11, 2019 - 12:18 CDT
Monitoring
Over the weekend, our Engineering team made significant progress toward resolving the Exchange latency that was being experienced. Mail flow and CPU performance remains optimal and we are closely monitoring to ensure that connectivity issues with our Exchange service have been fully resolved. We’ll post more on the final details and the root cause of this issue once the complete validation has been accomplished.
Posted 6 months ago. Mar 11, 2019 - 08:10 CDT
Update
Mail flow and message queues remain normal, but random OWA and Outlook timeouts are still occurring, along with intermittent connectivity drops resulting in authentication and password prompts for some Exchange customers. We continue to closely monitor and adjust our Exchange platform in order to counteract any experienced latency. AppRiver Engineering is diligently working with Microsoft to determine the underlying cause for this Exchange issue and will continue to do so throughout the weekend until the issue is identified and fully addressed.

Of course, any change or advancement in status will be posted and shared throughout the weekend – but we won’t post unnecessary updates as long as the status remains the same.
Posted 7 months ago. Mar 08, 2019 - 14:57 CST
Update
Mail flow and message queues remain stable and we are monitoring and adjusting performance as possible in order to counteract any experienced latency, which still may be resulting in intermittent authentication issues, password prompts and possible sluggishness for some of our Exchange users. Engineering personnel from both AppRiver and Microsoft are still actively working to uncover and fully address the root cause of the connectivity issues impacting our Exchange service. More status updates to come as we continue to work towards a full resolution.
Posted 7 months ago. Mar 08, 2019 - 12:10 CST
Update
Mail flow remains normal, but random authentication and password prompts are still occurring and we’re still experiencing brief connectivity issues with Exchange. Our Engineers are still troubleshooting the root cause directly with Microsoft and we will continue to update status as progress is made.
Posted 7 months ago. Mar 08, 2019 - 10:03 CST
Update
Our Engineering team continues to troubleshoot the issue with Microsoft that is impacting Exchange. Mail flow is currently normal, although intermittent latency is still causing authentication and password prompts for some customers. We are still actively working the issue and will continue to post with frequency until the issue is fully resolved.
Posted 7 months ago. Mar 08, 2019 - 07:30 CST
Update
Troubleshooting with Microsoft continues. Mail flow remains normal, although some customers are still experiencing random OWA and Outlook timeouts, as well as intermittent latency with regards to authentication and password prompts. We’re still actively working to resolve the issue and will continue to post more as progress is made towards a resolution.
Posted 7 months ago. Mar 07, 2019 - 15:39 CST
Update
Our Exchange service is still experiencing random connectivity issues in OWA and Outlook, including password prompts and authentication requests for many of our customers. Our Engineering team is working directly with Microsoft to troubleshoot the issue. Additional status updates will be posted as we make progress towards a resolution.
Posted 7 months ago. Mar 07, 2019 - 14:03 CST
Update
Our Engineering team continues to work with Microsoft to fully resolve this issue. Random connectivity delays with password prompts and authentication requests are still occurring, but mail flow is currently normal. We are actively monitoring the issue and will continue to post status updates as progress is made.
Posted 7 months ago. Mar 07, 2019 - 13:19 CST
Update
Exchange continues to experience random connectivity issues, which is resulting in authentication and password prompts for some customers. Experienced delays are still low and we continue to troubleshoot the issue with Microsoft. Next status update to be posted around 1300 CST.
Posted 7 months ago. Mar 07, 2019 - 11:14 CST
Update
Our Exchange service is still experiencing random connectivity issues, but associated delays are lessening. We are working to keep any delays to a minimum and continue to work with Microsoft to troubleshoot the issue. More status updates to come as we continue to work through the issue.
Posted 7 months ago. Mar 07, 2019 - 10:15 CST
Update
Our Exchange service continues to experience delays and connection issues. We have escalated the issue and are working with Microsoft to troubleshoot further. Status will be frequently updated as we continue to work to resolve the issue.
Posted 7 months ago. Mar 07, 2019 - 09:19 CST
Update
Mail flow has remained stable throughout the evening. Our engineering staff continues to troubleshoot and monitor the issue. More information to come as we continue to work through the issue.
Posted 7 months ago. Mar 07, 2019 - 07:25 CST
Update
Mail flow has returned to normal, but we're still troubleshooting the underlying cause of the connectivity issues.
Posted 7 months ago. Mar 06, 2019 - 22:54 CST
Update
We are still investigating the issue impacting Exchange and have temporarily disabled mail flow in stages in order to troubleshoot fully. More info to come as we continue to work through the issue.
Posted 7 months ago. Mar 06, 2019 - 20:53 CST
Update
Mail queues have cleared and performance is improving. Our engineers are still investigating.
Posted 7 months ago. Mar 06, 2019 - 18:42 CST
Update
Mail flow has returned to normal, but we’re still noticing some authentication delays in Outlook and OWA. Our engineering team is still investigating.
Posted 7 months ago. Mar 06, 2019 - 15:51 CST
Investigating
Customers with Exchange services may be experiencing sluggish or non-responsive client connectivity. We are currently investigating.
Posted 7 months ago. Mar 06, 2019 - 14:48 CST
This incident affected: Customer Portals & User Interfaces (Customer Portal) and Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).