OWA display issues for EMEA Region Hosted Exchange
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Oct 18, 2021 - 13:50 CDT
Monitoring
A fix has been implemented and we are monitoring the results. We do appreciate your patience.
Posted Oct 18, 2021 - 11:32 CDT
Update
The team is still investigating the issue. We will update status as we have more information.
Posted Oct 18, 2021 - 09:50 CDT
Investigating
We are currently investigating an issue with customers in our EMEA region experiencing display issues with OWA for our hosted exchange platform. We apologize for the inconvenience and appreciate your patience while we investigate the issue.
Posted Oct 18, 2021 - 07:23 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).