Exchange Online Service Alert - Exchange Admin Center
Incident Report for Zix | AppRiver
Resolved
Exchange Online service alert

Incident information
Title: Admins are unable to access the Exchange admin center
ID: EX382252

Status
Service Restored
Impacted Services

Exchange Online

Details
Title: Admins are unable to access the Exchange admin center

User Impact: Admins were unable to access the Exchange admin center (EAC).

Final status: While reproducing the issue internally, we've confirmed that the spike in CPU utilization has leveled off and the service has recovered. Additional monitoring and customer reports have validated that access to the EAC has been restored in all impacted regions.

Scope of impact: Impact was specific to a subset of users who were served through the affected infrastructure. Telemetry indicated that the majority of impact occurred to admins located in the North America and Europe regions.

Start time: Thursday, May 19, 2022, at 1:17 PM UTC
End time: Thursday, May 19, 2022, at 2:35 PM UTC

Preliminary root cause: A spike in CPU utilization on components which facilitate EAC access resulted in impact.
Next steps:
- We’re reviewing our code for improved performance and potential automated recovery options to reduce or avoid similar impact in the future.

Thank you,
The Microsoft team
Posted May 19, 2022 - 11:04 CDT
Investigating
Exchange Online service alert

Incident information
Title: Admins are unable to access the Exchange admin center
ID: EX382252

Status
Investigating

Impacted Services
Exchange Online

Details
Title: Admins are unable to access the Exchange admin center
User Impact: Admins are unable to access the Exchange admin center (EAC).
Current status: We're reviewing support case details and diagnostic data to isolate the source of the issue.
Scope of impact: Impact is specific to a subset of admins who are served through the affected infrastructure.
Next update by: Thursday, May 19, 2022, at 3:00 PM UTC

Thank you,
The Microsoft team
Posted May 19, 2022 - 09:26 CDT
This incident affected: Office 365.