Microsoft Service Health Notification - EX265850
Incident Report for Zix | AppRiver
Resolved
Advisory information
Title: Shared calendars may been unviewable within the Outlook client or Outlook on the web
ID: EX265850

Status
Service Restored

Details
Title: Shared calendars may been unviewable within the Outlook client or Outlook on the web
User Impact: Users may have been unable to view shared calendars within the Outlook client or Outlook on the web services.

More info: While we were focused on remediation, users may have been able to access shared calendars by granting anonymous permissions or by publishing an internet calendar.

Final status: We've confirmed that the deployment has completed and the fix has reached all affected areas. Our telemetry indicates that the service has been restored.

Scope of impact: This issue could have affected any user if they're attempted to view a shared calendar through the Outlook client or Outlook on the web.

Start time: Friday, May 28, 2021, at 12:00 AM UTC
End time: Sunday, July 11, 2021, at 9:39 AM UTC

Root cause: A recent change intended to update the Substrate application .net framework unexpectedly resulted in impact.

Next steps:
- We're reviewing our deployment procedures to help prevent similar problems in the future.
- We’re reviewing our code for improved performance and potential automated recovery options to reduce or avoid similar impact in the future.
This is the final update for the event.
Posted Jul 12, 2021 - 10:29 CDT
Identified
Advisory information
Title: Shared calendars not viewable within Outlook client or Outlook on the web
ID: EX265850

Status
Service Degradation

Details
Title: Shared calendars may not be viewable within Outlook client or Outlook on the web

User Impact: Users may be unable to view shared calendars within the Outlook client or Outlook on the web services.

More info: While we're focused on remediation, users may be able to access calendars shared using the Anonymous rules in the sharing policy, or use the Internet published calendar.
We'd like to get your feedback on the workaround we provided. From a non-mobile device, please rate this post and submit it in the textbox.

Current status: We’re reviewing recent calendar service infrastructure updates to the operating system (OS) and .NET version for changes that may have introduced the problem. Additionally, we're attempting to reproduce the impact in our testing environment, which will give us a more detailed view into the root cause and inform our next troubleshooting steps.

Scope of impact: This issue could potentially affect any user if they're attempting to view a shared calendar through the Outlook client or Outlook on the web.
Posted Jul 02, 2021 - 07:33 CDT
This incident affected: Office 365.