AETP/ETP Mail Flow Issue
Incident Report for AppRiver
Resolved
Our engineers were able to investigate and resolve any issues resulting from the Customer Portal/Partner Portal issue. We apologize for any inconvenience this may have caused.
Posted Oct 20, 2021 - 03:19 CDT
Investigating
We are currently investigating an issue where some users may experience mail flow delays. We will provide more information as it becomes available and apologize for any inconvenience.
Posted Oct 20, 2021 - 00:29 CDT
This incident affected: Email Security.