Two Factor Authentication Delays
Incident Report for AppRiver
Resolved
The delay impacting delivery of our two factor authentication codes has been fully resolved.
Posted Aug 27, 2019 - 13:23 CDT
Investigating
We are aware that two factor authentication verification codes are being delayed, particularly with Sprint devices. Our delivery provider is aware and is currently working to resolve (https://status.twilio.com).
Posted Aug 27, 2019 - 10:25 CDT
This incident affected: Customer Portals & User Interfaces (Customer Portal).