Hosted Exchange Delays
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 22, 2019 - 20:28 CST
Identified
We are currently upgrading our infrastructure and have noticed intermittent delays for Hosted Exchange as a result. While delays are brief for inbound messages, we expect additional delays to level off as we complete our infrastructure upgrades.
Posted 5 months ago. Feb 22, 2019 - 12:25 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).