Zix.com website issues
Incident Report for Zix | AppRiver
Resolved
Zix|Appriver has resolved the temporary issue with the zix.com website at approximately 11:55AM (CT). During this issue, you would not have been able to access zix.com.

We apologize for any inconvenience this may have caused.
Posted Jun 18, 2021 - 11:59 CDT
Identified
Zix|Appriver is currently experiencing an issue with the zix.com web site which started at approximately 11:00AM (CT). During this issue you will not be able to access zix.com.


We apologize for any inconvenience this may have caused.
Posted Jun 18, 2021 - 11:32 CDT