Customer Portal Maintenance Page
Incident Report for AppRiver
Resolved
The issue impacting Customer Portal availability has been fully resolved.
Posted 23 days ago. May 01, 2019 - 16:10 CDT
Monitoring
Customer Portal availability has been restored and we continue to monitor performance.
Posted 23 days ago. May 01, 2019 - 15:41 CDT
Update
We continue to investigate the issue that's impacting Customer Portal availability. While we have seen overall improvements, performance remains slow. More information to come.
Posted 23 days ago. May 01, 2019 - 14:30 CDT
Investigating
We are currently investigating an issue with the Customer Portal. The maintenance page is being displayed. More information to follow.
Posted 23 days ago. May 01, 2019 - 13:49 CDT
This incident affected: Customer Portals & User Interfaces (Customer Portal, Partner Portal, Billing Area).