MS has posted the following service alert advising the issue should now be resolved:
Current status: After reverting the offending service change, we’ve confirmed the service has recovered. Additionally, we've received confirmation from some affected customers that the issue was mitigated after the recent change was reverted. We're reviewing the service impact scenario to ensure we’ve fully addressed the issue and determine if any additional actions are required.
Posted Oct 17, 2023 - 16:42 CDT
Update
Quick Update from Microsoft:
We're reviewing our recent change history and have identified a potential problematic update that appears correlated with the known impact.
Posted Oct 17, 2023 - 14:52 CDT
Investigating
Microsoft has posted the following service incident:
Title: Admins may be receiving copies of outbound email to external parties originating from other users in their organization
User impact: Admins may be receiving copies of outbound email to external parties originating from other users in their organization
Current status: We are currently investing customer reports of an issue where Global Tenant Admins may be receiving an unexpected volume of copies of outbound external email originating from other users their organization and marked as potential spam. We will provide an update within 60 minutes.