Customer Portal Not Loading
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 07:35 CDT
Monitoring
Our engineers have deployed a fix and users should be able to access the Customer Portal at this time. We apologize for any inconvenience and will continue to monitor the situation.
Posted Oct 21, 2021 - 22:49 CDT
Investigating
We are currently investigating an issue where some users may not be able to reach the Customer Portal. We will provide more details as they become available.
Posted Oct 21, 2021 - 22:02 CDT
This incident affected: Email Security.