We have resolved the issue. We apoglize for the brief outage.
Posted Feb 25, 2025 - 14:19 CST
Investigating
We are currently investigating an issue with our Link Protection URL scanning not loading the websites correctly or returning a error on the scan. We apologize and are actively working to resolve this as soon as possible.
Posted Feb 25, 2025 - 14:06 CST
This incident affected: Threat Protection (Email Threat Protection).