Hosted Exchange Connectivity
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted May 04, 2021 - 09:23 CDT
Monitoring
Our exchange team was able to restore mail flow and connectivity to our Hosted Exchange service that was affecting our Zurich data center. We apologize for any inconvenience this may have caused and will continue to monitor performance throughout the day.
Posted May 03, 2021 - 09:25 CDT
Investigating
We are currently investigating an issue with Hosted Exchange where some users may experience mail delays or issues connecting to the service. Our engineers are investigating and we will update the status as more information is available.
Posted May 03, 2021 - 05:44 CDT
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).