Hurricane Sally Impacts
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 10:28 CDT
Identified
Hurricane Sally hit our area overnight and into this morning and has caused widespread power outages, which has created a shortage of available staff members to answer your calls and respond to your tickets in as quick a manner as we typically provide. We are working with all available corporate resources to answer calls, chats, and tickets, but there may be delays in availability of resources and responses until power is fully restored. We apologize for these delays and appreciate your patience as we work through the aftermath of the hurricane.
Posted Sep 16, 2020 - 10:06 CDT
This incident affected: Customer Portal Interface (Customer Portal, Partner Portal, Billing Area), Encryption Services (EMP/DeliverySlip), Support Infrastructure (Phone System, Live Chat), Email Continuity (Secure Cloud Email Continuity), Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)), Threat Protection (Email Threat Protection), Archive Services (Information Archive / ZCP), and Office 365, DNS Hosting.