Phone system issue
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted 16 days ago. May 30, 2019 - 08:01 CDT
Investigating
We are currently experiencing an issue with our phone system, which is affecting the quality of our calls. It has been determined that the issue is with our provider and we have escalated it to them for resolution. We will update this page once we have more information.
Posted 18 days ago. May 28, 2019 - 14:06 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).