Exchange Outlook Disconnects
Incident Report for AppRiver
Update
We continue to work with Microsoft on the issue, but in the interim have enacted more efficiencies that have reduced server load and the number of users per server in order to counteract any customer impacts.

We will provide further updates as the solution with Microsoft progresses.
Posted Sep 03, 2019 - 09:21 CDT
Update
We continue to work with Microsoft on a patch for the experienced Outlook disconnect issue. The network maintenance performed over the weekend helped mitigate some experienced disconnects. However, users may still be experiencing random isolated disconnects and we continue to work towards a resolution.
Posted Aug 27, 2019 - 12:14 CDT
Investigating
A few of our Exchange users may have experienced Outlook disconnects. Our Exchange engineers have identified an internal test that is failing a health check and are investigating further.
Posted Aug 09, 2019 - 13:31 CDT
This incident affects: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).