ETP Inbound Mail Flow Issue
Incident Report for Zix | AppRiver
Resolved
We have resolved the mail flow issues and confirmed mail is flowing again. We apologize for any inconvenience this may have caused.
Posted Sep 14, 2021 - 09:41 CDT
Investigating
We are currently investigating an issue with inbound mail flow in our European data center. We do apologize for the inconvenience and appreciate your patience. We will update status as we receive more information.
Posted Sep 14, 2021 - 05:19 CDT
This incident affected: Threat Protection (Email Threat Protection).