Email Security Delays
Incident Report for AppRiver
Resolved
Queues have cleared and mail flow has been fully restored.
Posted 3 months ago. Jun 24, 2019 - 15:01 CDT
Monitoring
We have identified and corrected the issue affecting mail flow for Email Security. Existing queues are in the process of clearing and mail flow is quickly returning to normal.
Posted 3 months ago. Jun 24, 2019 - 14:27 CDT
Investigating
We are investigating reports of mail delays for Email Security. Our internal teams are working to diagnose and address the issue. More info to follow.
Posted 3 months ago. Jun 24, 2019 - 13:42 CDT
This incident affected: Email Security.