Possible Mail Delays
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted May 14, 2021 - 16:27 CDT
Monitoring
Our engineering team identified an issue with some messages not being processed properly through the filter servers for certain recipients causing messages to queue. This was quickly identified and a fix was implemented, but it took some time to have all messages cleared and pushed out from the queue resulting in the delays. We certainly apologize for any inconvenience this has caused as we understand the importance of timely mail.
Posted May 13, 2021 - 17:14 CDT
This incident affected: Threat Protection (Email Threat Protection).