Filtering Delays
Incident Report for Zix | AppRiver
Resolved
The reported delays experienced with our Email Security filtering have been fully resolved. Engineering continues to closely monitor and is further investigating the root cause.
Posted Mar 14, 2019 - 12:05 CDT
Investigating
We are investigating some reported delays that are being experienced with our Email Security filtering service. Delays are not being noticed across the board and our engineering team is investigating.
Posted Mar 14, 2019 - 09:58 CDT
This incident affected: Threat Protection (Email Threat Protection).