Kaseya Compromise Information
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Aug 13, 2021 - 15:01 CDT
Monitoring

Zix is aware of a compromise that impacts Kaseya Limited, a software vendor that supports the Managed Service Provider (MSP) market through its VSA tools. More details can be found here:


Important Notice July 3rd, 2021 – Kaseya


Kaseya supply chain attack delivers mass ransomware event to US companies | by Kevin Beaumont | Jul, 2021 | DoublePulsar


Zix does not run any Kaseya software or systems.  We are reviewing and implementing proactive measures to harden our security based on the industry learnings from this breach.


Thank you for your continued support.

Posted Jul 03, 2021 - 12:39 CDT