Datacenter Issue Causing Mail Delays
Incident Report for AppRiver
Resolved
The datacenter issue that was impacting Exchange mail flow has been fully resolved.
Posted about 1 month ago. Feb 20, 2019 - 08:22 CST
Identified
An identified datacenter infrastructure issue is resulting in mail delays for our Exchange customers. We are currently working to resolve the issue and will post additional status updates as available.
Posted about 1 month ago. Feb 20, 2019 - 08:04 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).