ETP delays to Office 365
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted May 10, 2021 - 09:18 CDT
Monitoring
Mail flow has returned to normal process speeds and we are actively engaged with Microsoft to monitor if any issues occur. We apologize for any inconvenience this may have caused.
Posted May 07, 2021 - 13:50 CDT
Investigating
We are currently investigating issues with delayed emails from our filters to Office 365. We are actively working with Microsoft to resolve this. We apologize for any inconvience this may cause.
Posted May 06, 2021 - 13:14 CDT
This incident affected: Threat Protection (Email Threat Protection).