Unable to access Customer Portal
Incident Report for AppRiver
Resolved
This issue has been resolved.
Posted Nov 04, 2021 - 17:52 CDT
Investigating
We are currently experiencing issues with logging into our Customer Portal. We are aware of and are actively working on this issue. We apologize for any inconvenience this may cause.
Posted Nov 04, 2021 - 15:28 CDT
This incident affected: Secure Cloud Platform (Customer Portal).