Customer Portal errors
Incident Report for AppRiver
Resolved
We have corrected the issue and we confirmed access to the Customer Portal is operating as normal. We apologize for any inconvenience this may have caused.
Posted May 11, 2022 - 13:10 CDT
Investigating
We are currently investigating issues with accessing the Customer Portal. We apologize for this inconvenience this is causing.
Posted May 11, 2022 - 12:46 CDT
This incident affected: Secure Cloud Platform (Customer Portal).