Phone Outage
Incident Report for AppRiver
Resolved
AppRiver's phone system is operating properly now.
Posted over 1 year ago. Jan 31, 2018 - 10:06 CST
Investigating
Customers calling in to AppRiver may get a busy signal as we investigate an issue with our phone system. However, live chat and the ticket system are still functioning properly. If you have a customer support issue, please contact us using live chat or email and our team will respond.
Posted over 1 year ago. Jan 31, 2018 - 09:34 CST