O365 US based licensing issue
Incident Report for Zix | AppRiver
Resolved
The licensing issue has been resolved, we appreciate your understanding and do apologize for the inconvenience.
Posted Jan 14, 2022 - 06:58 CST
Identified
We are currently experiencing an issue with ordering licensing for Office 365. We do apologize for this inconvenience and appreciate your patience as we work with Microsoft to resolve the issue. Updates will be posted to stats as we have them.
Posted Jan 13, 2022 - 12:30 CST
This incident affected: Customer Portal Interface (Customer Portal) and Office 365.