Hosted Exchange Delays
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 05:54 CST
Monitoring
A fix has been implemented and mail flow has now returned to normal. We will continue to monitor and apologize for any inconvenience this may have caused.
Posted Jan 01, 2022 - 00:37 CST
Identified
Our engineers have identified the issue and are currently implementing the fix to affected server sets. We will post additional information as it becomes available.
Posted Dec 31, 2021 - 23:24 CST
Investigating
We are currently investigating an issue where some users are reporting mail delays with our Hosted Exchange Service. As more information becomes available we will post it here. We apologize for the inconvenience.
Posted Dec 31, 2021 - 21:56 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).