Mail Flow Issues
Incident Report for Zix | AppRiver
Resolved
This issue has been resolved. Customers may still experience delays as mail flow returns to normal.
Posted May 31, 2019 - 10:20 CDT
Investigating
We are currently aware of intermittent mail flow delays and are investigating the issue.
Posted May 31, 2019 - 08:47 CDT
This incident affected: Threat Protection (Email Threat Protection).