Inbound Phone/IVR issue
Incident Report for AppRiver
Resolved
We have resolved this issue with our phone provider. We apologize for the inconvenience this may have caused.
Posted Jul 09, 2021 - 16:17 CDT
Investigating
Zix is currently experiencing an issue with our primary support toll-free number, which began at approximately 12:00 PM (CT). During this time please email support@appriver.com OR you may call 1-850-932-5338. Our provider is working on the issue and we expect this to be resolved shortly.
Posted Jul 09, 2021 - 13:03 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).