Exchange Online Service Alert - New Contact option on Outlook on the web
Incident Report for Zix | AppRiver
Resolved
Exchange Online service alert

Advisory information
Title: Users couldn't see the New Contact option on Outlook on the web
ID: EX313328

Status
Service Restored
Posted Jan 11, 2022 - 13:10 CST
Monitoring
Exchange Online service alert

Advisory information
Title: Users couldn't see the New Contact option on Outlook on the web
ID: EX313328

Status
Service Restored

Details
Title: Users couldn't see the New Contact option on Outlook on the web

User Impact: Users were unable to see the New Contact option on Outlook on the web.

More info: This issue was affecting Outlook on the web versions 20220103004.09 or higher.

Final status: The fix has been finalized and deployed. We've confirmed that the issue have been successfully mitigated after monitoring the affected environment.

Scope of impact: This issue may have potentially affected any of your users attempting to add a new contact in Outlook on the web.

Start time: Friday, January 7, 2022, at 7:05 AM UTC
End time: Tuesday, January 11, 2022, at 1:50 PM UTC

Root cause: A recent update to the People services inadvertently resulted in impact.
Next steps:
- We're reviewing our update procedures to better identify similar issues during our development and testing cycles.

This is the final update for the event.

Thank you,
The Microsoft team
Posted Jan 11, 2022 - 09:06 CST
Investigating
Exchange Online service alert

Advisory information
Title: Users can't see the New Contact option on Outlook on the web
ID: EX313328

Status
Service Degradation

Details
Title: Users can't see the New Contact option on Outlook on the web

User Impact: Users are unable to see the New Contact option on Outlook on the web.

More info: Users are able to see the New Contact option when using Internet Explorer 11.

Current status: We're continuing our review of network traces and PSR logs as we conduct testing on internal reproductions of the issue to assist our investigation.

Scope of impact: Your organization is affected by this event, and any user attempting to add a new contact in Outlook on the web is impacted.

Next update by: Tuesday, January 11, 2022, at 8:00 AM UTC

Thank you,
The Microsoft team
Posted Jan 11, 2022 - 07:11 CST
This incident affected: Office 365.