EMEA Server Connection Issues
Incident Report for Zix | AppRiver
Resolved
This issue has been resolved. Green.ch datacenter reported at 15:36 p.m., a malfunction was registered on their network systems. Several green services were affected. The technicians there resolved the issue at approximately 16:10 p.m.
Posted Nov 19, 2020 - 11:14 CST
Identified
It has been identified that a local Green.ch datacenter is having an interruption with its services. They are currently working to correct the issue.
Posted Nov 19, 2020 - 11:08 CST
Investigating
We are currently investigating issue with some EMEA customers seeing connecting issue. Our engineers are investigating the issue with the data center and local ISP's.
Posted Nov 19, 2020 - 10:19 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).