Office 365 Exchange Online delay
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 22:00 CST
Investigating
Users may not be receiving email or may experience delays in receiving email in Exchange Online

User impact: Users may not be receiving email or may experience delays in receiving email in Exchange Online.

Title: Users may not be receiving email or may experience delays in receiving email in Exchange Online

User Impact: Users may not be receiving email or may experience delays in receiving email in Exchange Online.

Current status: We've determined that a portion of infrastructure that facilitates timely processing of Exchange Online email is performing below service standards, resulting in email queues and causing delays in receiving email. We're restarting the impacted infrastructure and monitoring email queue processing.

Scope of impact: Any user may intermittently not receive email or experience delays receiving email in Exchange Online.

Next update by: Friday, January 15, 2021, at 11:30 PM UTC
Posted Jan 15, 2021 - 16:38 CST
This incident affected: Office 365.