Spam Stop Here/Zix Protect delivery issues to Office 365
Incident Report for AppRiver
Resolved
We have confirmed the issue has been resolved and the queues have all been released. We apologize for this issue as we understand that timely email of the uttermost importatance.
Posted Jul 14, 2021 - 14:06 CDT
Monitoring
We are seeing successful relays of emails and the queues are steadily dropping. We are actively monitoring the queues as well to ensure we do not see the same issues occur on the delivery. We apologize for any issues this may have caused.
Posted Jul 13, 2021 - 17:46 CDT
Identified
We have identified the issue to a subset of customers delivering to Microsoft. We are actively engaged with them to resolve this issue as soon as possible. We extremely apologize for this issue and understand the importance of timely email flow.
Posted Jul 13, 2021 - 16:29 CDT
Investigating
We are currently seeing issues with delivery from Spam Stops Here/Zix Protect services to Office 365 tenants. We are currently investigating this issue and are working on rectifying this issue immediately. We apologize for any inconvenience this may be causing.
Posted Jul 13, 2021 - 07:59 CDT
This incident affected: Email Security.