HEX Mail Delays

Incident Report for Zix | AppRiver

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 16:07 CST

Monitoring

We are seeing the delayed mail clear out and returning to normal flow. Our engineering team is continuing monitor.
Posted Feb 26, 2025 - 19:22 CST

Investigating

Some user mailboxes are reporting delays receiving mail.
Posted Feb 26, 2025 - 16:53 CST
This incident affected: Secure Hosted Exchange (Exchange 2013/2016+ (EXG7)).