Customer Portal
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted Mar 31, 2021 - 19:59 CDT
Identified
Our engineering and development teams are continuing to investigate this issue.
Posted Mar 31, 2021 - 14:02 CDT
Investigating
We have identified an issue that is causing some user to see longer than normal performance times and are actively working on correcting this issues.
Posted Mar 31, 2021 - 13:29 CDT
This incident affected: Customer Portal Interface (Customer Portal).