ETP delivery issues
Incident Report for Zix | AppRiver
Resolved
We have resolved this issue. We apologize for the inconvenience this caused.
Posted May 09, 2022 - 16:58 CDT
Identified
We are currently experience a issue with a small subset of our filter that is effecting mail flow. We are actively working to resolve this issue.
Posted May 09, 2022 - 15:38 CDT
This incident affected: Threat Protection (Email Threat Protection).