Customer Portal performance issues
Incident Report for Zix | AppRiver
Resolved
This incident has been resolved.
Posted May 05, 2021 - 12:53 CDT
Investigating
We are currently investigating reports of Customer Portal performance issues. We appreciate your patience and will update as we have more information available.
Posted May 05, 2021 - 11:03 CDT
This incident affected: Customer Portal Interface (Customer Portal).