Customer Portal
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 12:40 CDT
Identified
We have identified an issue that is causing some user to see longer than normal login times and are actively working on correcting this issues.
Posted Apr 30, 2020 - 10:44 CDT
This incident affected: Secure Cloud Platform (Customer Portal).