Email Message Privacy Service
Incident Report for Zix | AppRiver
Resolved
The delays some users were seeing when logging into their portal has been resolved. We will continue to monitor.
Posted Sep 14, 2020 - 14:43 CDT
Identified
Engineers have identified the issue that is causing the login delays for some users and are actively working to correct the issue.
Posted Sep 14, 2020 - 12:24 CDT
Investigating
We are currently experiencing an issue where some users are seeing slow login times to their secure messaging portals.
Posted Sep 14, 2020 - 12:22 CDT
This incident affected: Encryption Services (EMP/DeliverySlip).