Inbound deliverability issues
Incident Report for AppRiver
Resolved
This issue has been resolved. We apologize for any inconvenience this may have caused.
Posted Jun 14, 2022 - 14:05 CDT
Identified
We are currently experiencing an issue with a small set of customers for inbound delivery of emails. We are actively working this issue. We apologize for any inconvenience this may be causing.
Posted Jun 14, 2022 - 12:36 CDT
This incident affected: Email Security.