Customer Portal Exchange section inaccessible
Incident Report for AppRiver
Resolved
We have resolved the issue and confirmed all functions of the Customer Portal are operational. We apologize for any inconvenience this may have caused.
Posted Oct 04, 2021 - 10:03 CDT
Update
We are still actively working to resolve this issue. We have discovered that user management/password syncs are also affected. We apologize for any inconvenience this may be causing.
Posted Oct 04, 2021 - 09:08 CDT
Investigating
We are currently are experiencing an issue with our Exchange section in the Customer Portal. We are actively investigating this however we confirmed it is only affecting the Customer Portal and mailboxes are not affected during this time. We apologize for any inconvenience this may cause.
Posted Oct 04, 2021 - 08:00 CDT
This incident affected: Secure Cloud Platform (Customer Portal).