Delayed message delivery for SMB and MT/AEE/ZEE due to Microsoft IP blocking
Incident Report for Zix | AppRiver
Resolved
Microsoft has marked this issue as resolved with the modification of the code they implemented the night before.

All of our queues that had mail build up have been cleared and mail operations have resumed to normal flow.

We do apologize for inconvenience with this issue.

Thank you
Posted Oct 12, 2023 - 09:58 CDT
Update
Microsoft has deployed a hotfix and mail is flowing again. We are continuing to monitor.
Posted Oct 11, 2023 - 13:47 CDT
Update
Current status: We’re progressing with the testing and development stage of our fix, to ensure its efficacy prior to deployment. We expect to be able to provide an estimate time of completion by the time of the next scheduled update.
Posted Oct 11, 2023 - 10:27 CDT
Update
Current status: We’ve identified that a recent service update, applied to a section of infrastructure responsible for enforcing IP address anti-spam rules, contains a change which is inadvertently causing impact. We’re developing and validating a fix to revert to the most recent stable service version to remediate impact. In parallel, we’re continuing to manually add reported affected IP addresses to an allowed list to alleviate impact in the short term.
Posted Oct 11, 2023 - 08:35 CDT
Identified
Microsoft has posted the following Service Alert:

Title: Some users may encounter delays receiving external email messages in Exchange Online

User impact: Users may encounter delays receiving external email messages in Exchange Online.

More info: Affected users may see a "451 4.7.500 Server busy" error message.

Current status: We’ve identified that specific IP addresses are being unexpectedly limited by our anti-spam procedures, causing external email delivery to become throttled and delayed. We're reviewing if there have been any recent changes to our anti-spam rules to understand why the IP addresses are being limited. In the meantime, we're manually adding reported affected IP addresses to an allowed list to provide immediate relief.
Posted Oct 11, 2023 - 07:11 CDT
Investigating
We are currently investigating this issue.
Posted Oct 11, 2023 - 01:34 CDT
This incident affected: Encryption Services (Hosted SMB, Secure Cloud Email Encryption (AEE/ZEE)).