Gulf Breeze Evacuation
Incident Report for AppRiver
Resolved
Our Support personnel are in place and the phone lines are open.
Posted 3 months ago. Jun 17, 2019 - 11:25 CDT
Investigating
Due to a fire alarm and temporary evacuation at our Gulf Breeze location, there will be a short time while we relocate support personnel for phone line access, which will be in place within 30 minutes.
Posted 3 months ago. Jun 17, 2019 - 11:01 CDT
This incident affected: Support Infrastructure (AppRiver Phone System).