The re-scans have been complete. We apologize for any inconvenience this may have caused.
Posted Oct 28, 2024 - 12:07 CDT
Monitoring
Our re-scan is in process now and should complete shortly.
Posted Oct 28, 2024 - 11:13 CDT
Identified
We have identified an overly aggressive rule this morning that was capturing a large percentage of valid emails. We have corrected the rule and are in the process of automating the release of all emails that were captured by this rule. We apologize for this inconvenience.
Posted Oct 28, 2024 - 11:11 CDT
This incident affected: Threat Protection (Email Threat Protection).