Exchange Online Service Alert - possible mail delays
Incident Report for Zix | AppRiver
Resolved
September 9, 2022 2:11 PM
Title: Users’ inbound email messages may be delayed up to 15 minutes

User impact: Users’ inbound email messages may have been delayed up to 15 minutes.

More info: This issue likely affected all Exchange Online connection methods.

Final status: We’ve confirmed that the fix has successfully saturated throughout the affected environment. Additionally, we’ve verified via monitoring the service and with affected users that this action has remediated the problem.

Scope of impact: All users whose mailboxes were located on the affected mailbox infrastructure experienced inbound email delays of up to 15 minutes.

Start time: Thursday, September 1, 2022, 10:28 AM (3:28 PM UTC)

End time: Friday, September 9, 2022, 12:00 AM (5:00 AM UTC)

Root cause: A portion of mailbox infrastructure was experiencing performance issues.

Next steps:
- We're investigating why the portion of mailbox infrastructure was experiencing performance issues to prevent this problem from happening again in the future.

This is the final update for the event.
Posted Sep 12, 2022 - 11:36 CDT
Investigating
Exchange Online service alert

Advisory information
Title: Users’ inbound email messages may be delayed
ID: EX427706

Status
Service Degradation

Affected Services
Exchange OnlineExchange Online, Exchange Online

Details
Title: Users’ inbound email messages may be delayed

User Impact: Users’ inbound email messages may be delayed in delivery.

More info: This issue likely affects all Exchange Online connection methods.

Current status: We’ve completed the validation process for our intended fix, and we’ve confirmed its efficacy in resolving impact. We’re initiating deployment of the fix to the affected service environments to restore mail flow and repair this issue, and we’re aiming to provide a timeline for deployment and impact remediation in our next update.

Scope of impact: All users’ inbound email routed through the affected environment is impacted.

Root cause: A portion of mailbox infrastructure is experiencing performance issues.

Next update by: Friday, September 9, 2022, at 12:00 AM UTC

Thank you,
The Microsoft team
Posted Sep 08, 2022 - 13:22 CDT
This incident affected: Office 365.