Users are unable to send outbound email messages in Exchange Online
Incident Report for Zix | AppRiver
Resolved
Title: Users are unable to send outbound email messages in Exchange Online

User impact: Users are unable to send outbound email messages in Exchange Online.

More info: Impact was specific to sending email messages to addresses outside of their organization. Email messages sent to other users within the organization weren't impacted.

Users saw the following within the NDR message: "Remote server returned '550 5.7.705 Access denied, tenant has exceeded threshold"

Affected users would have encountered this issue in all Exchange Online connection methods.

Final status: We've confirmed through user feedback and internal telemetry monitoring of NDR occurrences that disabling the problematic anti-spam rule has resolved the issue.

Scope of impact: Some users attempting to send email messages to users outside of their organization may have been impacted.

Start time: Monday, April 10, 2023, 4:00 AM (9:00 AM UTC)

End time: Monday, April 10, 2023, 1:45 PM (6:45 PM UTC)

Root cause: A recently updated anti-spam rules wasn't processing or evaluating email data as expected, resulting in impact.

Next steps:
- We're reviewing our anti-spam rule update processes and testing procedures to help prevent problems like this in the future prior to implementation.
- We're additionally evaluating telemetry indicators, such as NDR increases, to better detect problems like this.

This is the final update for the event.
Posted Apr 11, 2023 - 07:08 CDT
Identified
April 10, 2023 3:11pm
Title: Users are unable to send outbound email messages in Exchange Online

User impact: Users are unable to send outbound email messages in Exchange Online.

More info: Impact is specific to sending email messages to addresses outside of their organization. Email messages sent other users within the organization aren’t impacted.

Users will see the following within the NDR message: "Remote server returned '550 5.7.705 Access denied, tenant has exceeded threshold"

Affected users will encounter this issue in all Exchange Online connection methods.

Current status: We've received positive feedback from some users that they can send external email as expected. We're continuing to wait for additional users to validate remediation, while we monitor telemetry which indicates that fewer users are receiving the NDR messages since we've disabled the rule. Additionally, we're further analyzing the anti-spam rule which we've disabled to understand the underlying root cause and to prevent impact from reoccurring.

Scope of impact: Some users attempting to send email messages to users outside of their organization may be impacted.

Next update by: Monday, April 10, 2023, 8:00 PM (4/11/2023, 1:00 AM UTC)
Posted Apr 10, 2023 - 15:31 CDT
Investigating
Title: Some users may be unable to send outbound email messages in Exchange Online

User impact: Users are unable to send outbound email messages in Exchange Online.

More info: Impact is specific to sending email messages to addresses outside of their organization. Email messages sent other users within the organization aren’t impacted.

Users will see the following within the NDR message: "Remote server returned '550 5.7.705 Access denied, tenant has exceeded threshold"

Affected users will encounter this issue in all Exchange Online connection methods.

Current status: Our review of NDRs provided by affected users is leading us to suspect that an anti-spam rule isn't behaving as expected and contributing to impact. We're investigating further to confirm this and to identify resolution options.

Scope of impact: Some users attempting to send email messages to users outside of their organization may be impacted.

Next update by: Monday, April 10, 2023, 3:00 PM (8:00 PM UTC)
Posted Apr 10, 2023 - 14:04 CDT
This incident affected: Office 365.