Unable to login to the Customer Portal
Incident Report for Zix | AppRiver
Resolved
This issue has been resolved. We apologize for any inconvenience this may have caused.
Posted Sep 15, 2021 - 07:07 CDT
Investigating
We are investigating an issue where users are currently unable to login to the Customer Portal. We apologize for the inconvenience and will post updates as soon as we have more information.
Posted Sep 15, 2021 - 05:49 CDT
This incident affected: Customer Portal Interface (Customer Portal).