Issue with MFA for the Customer Portal
Incident Report for AppRiver
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 11:50 CDT
Monitoring
MFA appears to be working now. We will monitor the situation and post to status if anything changes. We appreciate your patience and apologize for the inconvenience.
Posted Oct 27, 2021 - 09:11 CDT
Investigating
We are currently investigating reports with MFA for our Customer Portal where some customers are not receiving the SMS code. This appears to be an issue with the SMS vendor. We do apologize for this inconvenience and appreciate your patience as we work to resolve the issue. We will continue to post updates on status as we have them.
Posted Oct 27, 2021 - 08:00 CDT
This incident affected: Secure Cloud Platform (Customer Portal).